PJPEG videos drifting out of sync over time
  • rurik2000
    junior Member
    Posts: 6
    Joined: Sat Oct 24, 2015 11:40 am

    PJPEG videos drifting out of sync over time

    by rurik2000 » Fri Oct 30, 2015 9:41 am

    Hello

    I'm using a MacMini with a decent SSD to ouput to three projectors. My media is 1280x720, PJPEG 80% quality, which seems fine for the machine to handle.
    However as the show repeats over the course of a few hours, the outputs start drifting...

    Any hints as to how to avoid that?

    Thanks
  • franz
    madMapper master
    Posts: 797
    Joined: Fri Feb 18, 2005 7:05 pm
    Location: Paris, France
    Contact:

    Re: PJPEG videos drifting out of sync over time

    by franz » Fri Oct 30, 2015 11:39 am

    are your videos exactly the SAME frame numbers ?
    SAME FPS ?
    How do you start them ?
  • rurik2000
    junior Member
    Posts: 6
    Joined: Sat Oct 24, 2015 11:40 am

    Re: PJPEG videos drifting out of sync over time

    by rurik2000 » Fri Oct 30, 2015 1:01 pm

    Yes, I realized that there were a few frames of difference, my bad...

    I launch the videos by mapping keyboard controls to them...I stumbled upon that functionality by chance, thankfully, as I was about to explore some OSC driven external control :)
  • franz
    madMapper master
    Posts: 797
    Joined: Fri Feb 18, 2005 7:05 pm
    Location: Paris, France
    Contact:

    Re: PJPEG videos drifting out of sync over time

    by franz » Fri Oct 30, 2015 7:35 pm

    you need the EXACT SAME frame numbers and frame/persecond replay value.
    Then they should stay in sync.

    To be sure, your best best is still to make one movie with your 3 movies pre-sync'ed

Who is online

Users browsing this forum: No registered users and 5 guests