Lemur OSC & Madmapper
  • Sphazz
    junior Member
    Posts: 2
    Joined: Sat Oct 21, 2017 11:23 pm

    Lemur OSC & Madmapper

    by Sphazz » Fri Nov 02, 2018 11:30 pm

    Hello guys,

    I am having hard time to get Madmapper and Lemur working together through OSC and there is actually no specific tutorial on this...

    I have created a Adhoc network from my Mac named "Alex"
    Within the OSC Target I got:
    OSC O Host: Alex.local Port 8001
    Same thing under the App Editor

    I do have the Lemur Editor running and working with the App (with every UI object responding in real time)

    Now I want to change the color of my surface under Madmapper with the following OSC Address:
    /surfaces/Quad-1/color/red

    Going back to Lemur editor I copy this Custom Address to the corresponding field using Object Target "osc 0" and Target "Parent (Osc 0)" (i have tried different combination of this as it is not really clear to me how this works...)

    And nothing happens under Madmapper...

    What am I missing here?
  • Sphazz
    junior Member
    Posts: 2
    Joined: Sat Oct 21, 2017 11:23 pm

    Re: Lemur OSC & Madmapper

    by Sphazz » Sat Nov 03, 2018 8:39 pm

    Ok I figured this out...

    Stupid mistake:
    Make sure you have the right Port in the OSC preferences within Madmapper in Both the OSC Editor and the Preference.

    Also for a reason the Lemur App Editor auto-ip detect was putting a random IP address not matching with my real address.

    So make sure you enter a manual static address to be more secure for both your Adhoc server and your device running the Lemur App (for instance 192.168.0.1 for the router, 192.168.0.10 for your computer and 192.168.0.20)

Who is online

Users browsing this forum: Google [Bot] and 4 guests