Unicast LED lag issues - Madmapper
  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Unicast LED lag issues - Madmapper

    by Mjason » Thu May 09, 2019 10:53 am

    Hello!

    I am running 4 universes unicast through madmapper, into a pro light node, and to 10m of LEDbars, and i'm having some drops in fps after approximately 10-15 seconds, "Lines"-materials starts to look choppy etc. It's not a computer cpu issue as i have worked a bunch with much heavier projects and tried it on multiple computers. It looks as if it might be the Node that cant handle the traffic, but that sort of seems strange too, as it's built to withstand 4 universes with the LEDs i've bought from the same company.

    Is there maybe something in the setup of the unicast i have messed up? I'm attaching a photo of how my unicastsettings are set, only 4 lines with the same IP as the node, nothing more nothing less. Is there some additional settings that could be vital to making this work? (the ip address in the photo is not correct, its only for the sake of showing). I will also include a picture of the node i'm using.

    Appreciate any help! Thank you
  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Re: Unicast LED lag issues - Madmapper

    by Mjason » Thu May 09, 2019 10:57 am

  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Re: Unicast LED lag issues - Madmapper

    by Mjason » Thu May 09, 2019 11:11 am

    https://ibb.co/jkKQDxw

    Picture of unicast setup
  • mad-matt
    garageCube team
    Posts: 818
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Unicast LED lag issues - Madmapper

    by mad-matt » Sun May 12, 2019 9:02 pm

    Are you using broadcast or unicast ? If the "Unicast" checkbox is checked in MadMapper Preferences / DMX Output, then we use unicast (advised over 30 universes)
    To debug, you should setup ArtNet in broadcast (disable unicast), and use Luminet Monitor to look at the data & FPS (free download here). If it's choppy there it means the problem comes from MM (I have no doubt it won't be choppy there, except if it's choppy on the previews too)
    If it's clean there, you have to undertstand why your node doesn't like receiving the packets MadMapper is sending. MadMapper does send the ArtSync packets (part of ArtNet 4 spec) to ensure synchronization between universes. It's well implemented in most devices, ignored by lots of devices, but maybe some devices won't handle it properly...
    Let us know after the ArtNet monitoring with Luminet Monitor.
    Cheers
  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Re: Unicast LED lag issues - Madmapper

    by Mjason » Sun May 12, 2019 11:44 pm

    Issue was resolved(most likely). I was sending 4 universes unicast to a node that could only handle 3(even though it said it would take 4). Reducing to 3 universes in madmapper made the lagging stop.

    thanks for the reply!
  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Re: Unicast LED lag issues - Madmapper

    by Mjason » Tue May 14, 2019 6:29 pm

    To debug, you should setup ArtNet in broadcast (disable unicast), and use Luminet Monitor to look at the data & FPS (free download here).
    After consulting with the manifacturer of the node they reassured me that 4 universes should be no problem, so I would love to try the Luminet Monitor, but couldnt seem to find a link for it in your reply? Would you mind sending the link again?

    Thanks!
  • Mjason
    junior Member
    Posts: 9
    Joined: Sun Mar 25, 2018 2:04 am

    Re: Unicast LED lag issues - Madmapper

    by Mjason » Tue May 14, 2019 10:00 pm

    https://ibb.co/djyTh9z

    This means it should be fine for 4 universes, and the issue lies with the node, right?
  • mad-matt
    garageCube team
    Posts: 818
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Unicast LED lag issues - Madmapper

    by mad-matt » Wed May 15, 2019 3:49 pm

    Yes that means MadMapper sends correct the 4 universes in broadcast. So the pb relies in the node.

Who is online

Users browsing this forum: No registered users and 2 guests