Performance issues with MadMapper & Modul8
  • symbiosis
    junior Member
    Posts: 5
    Joined: Fri Jun 06, 2014 1:11 pm

    Performance issues with MadMapper & Modul8

    by symbiosis » Fri Jun 06, 2014 1:23 pm

    Hi,

    I bought a brand new top of the line MacBook Pro Retina 13" (specs below), and I'm having some performance issues with MadMapper (much like a breakdancing thing, really slow performance).
    Modul8 plays slightly better, but also flickering every now and then.

    MacBook Pro 11,1 - 13" inch
    2,8GHz Intel Core i7 processor
    16GB 1600MHz DDR3 Ram
    Intel Iris GPU with 1536MB VRAM
    512GB Flash Storage

    MadMapper v1.6.1
    Modul8 v2.7.1

    Videos: .mov and Photo JPEG codec at 75% (later tried with 50%, same result)

    With my previous computer (a MacBook Pro 13" Early 2011) it didn't happen; I usually play HD/Full HD videos to 2 video projectors, and while with the previous computer I used a splitter (Thunderbolt input to 2 HDMI outputs), in the Retina, for its multiple outputs, I can split the output for blending with no extra gear (or so I thought).

    Last weekend I had a massive problem because of this: was playing a 2x 16:10 resolution (1280x1600), and the quality of the show was terrible (it had like frame drops every 5 seconds or so). After, we made a test with a 15" Retina model, and the result was significantly better (probably due to the dedicated graphics card), but still with some performance issues in the playback.

    I can't understand how I didn't use to have this problem and now (with the new machine) it's giving me a hell of a headache...
    Can you guys give me any advise for this? I just invested all my money in this new computer, don't really know what to do if it doesn't work...

    Thanks
  • parratoro
    junior Member
    Posts: 2
    Joined: Sat Mar 12, 2016 1:44 am

    Re: Performance issues with MadMapper & Modul8

    by parratoro » Tue Mar 15, 2016 3:37 am

    I have the same issue!.. I own a top-of-the-line 15 inches MacBook Pro, and when I put 3 layers and the camera in one of them.. it's really slow fps.

    Also it's so weird how if I click with my pad it works, but when I touch-click it, it doesn't.. I have to do it several times. It's really frustrating.

    Also the dock doesn't shows at all when Modul8 is running and Mad Mapper gets really slow when I do more than 4 shapes.

    It's really unusable, I was willing to buy both, but it doesn't make any sense.. what is weird is that I see people use it, even on older machines than mine.. It's so frustrating. :(
  • franz
    madMapper master
    Posts: 753
    Joined: Fri Feb 18, 2005 7:05 pm
    Location: Paris, France
    Contact:

    Re: Performance issues with MadMapper & Modul8

    by franz » Sun Mar 20, 2016 7:37 pm

    are you running the latest MM version 2.2.3 ?
    We pimped the video engine on the 2.x branch and it is now super fast.
    On a sidenote, MBP 13" is a bit weak in terms of graphic card, it doesn't have a dedicated one

    Also, for large videos (HD or more) don't use photojpeg, use either H264 or HAP
  • symbiosis
    junior Member
    Posts: 5
    Joined: Fri Jun 06, 2014 1:11 pm

    Re: Performance issues with MadMapper & Modul8

    by symbiosis » Mon Mar 21, 2016 10:37 am

    franz wrote:Also, for large videos (HD or more) don't use photojpeg, use either H264 or HAP


    I was always told not to use H264, as it uses a lot of processing to decode, are you sure about this information?
  • Xaver2k
    super8 member
    Posts: 103
    Joined: Thu Feb 20, 2014 11:23 pm
    Location: Germany

    Re: Performance issues with MadMapper & Modul8

    by Xaver2k » Mon Mar 21, 2016 12:01 pm

    Franz said
    On a sidenote, MBP 13" is a bit weak in terms of graphic card, it doesn't have a dedicated one

    So he recommended you the H264 encoder because it uses the CPU to decode (instead of GPU). If you are running other stuff that needs heavy cpu load, it may be laggy too. Just try which one is better for your performance.

Who is online

Users browsing this forum: No registered users and 2 guests