3D-Object invisible after Calibration

For when you really get Mad at MadMapper

3D-Object invisible after Calibration

Postby the_chris » Thu Mar 23, 2017 11:03 am

Dear all,

I am working on a stage project and trying to match a 3D-model of our set design with the actual projection – in order to work with virtual "light effects".
Each time after I have finished the calibration tool, the object somehow disappears. I am not able to modify the mesh, add texture, grid or anything. It is not visible in the output section and the output itself. If I am editing the calibration, the object re-appears in the calibration mode.

Someone experienced this as well? Any ideas?

Best,
Chris
the_chris
Junior Member
 
Posts: 2
Joined: Thu Mar 23, 2017 10:57 am

Re: 3D-Object invisible after Calibration

Postby mad-matt » Fri Mar 24, 2017 11:49 am

It may happen when the object is too flat. The calibration matrix computed in some case looks wrong, but it shouldn't happen if you have volume. If you can't solve it, send your 3D object to support[at]garagecube[dot]com we'll have a look at it.
mad-matt
MadMapper master
 
Posts: 314
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3D-Object invisible after Calibration

Postby the_chris » Tue Mar 28, 2017 9:35 am

Hi mad-matt,

thanks a lot. Due to short time I worked around the problem and did not use the 3D-object. But very good to know for future projects.

Best,
Chris
the_chris
Junior Member
 
Posts: 2
Joined: Thu Mar 23, 2017 10:57 am

Re: 3D-Object invisible after Calibration

Postby TheYouth » Fri Jul 14, 2017 2:06 pm

Got same same issue, more or less...

Imported an sphere, created five calibration points, when creating the sixth the object disappears. When moving one of the points the object comes back, bit when moving 1pixel the objects moves several centimeters.... not accurate...
Yes, spheres are complex, but I hope it can be done with Madmapper :)
In the end I need 7 projectors or more...
TheYouth
Member
 
Posts: 15
Joined: Sun May 15, 2016 4:39 pm

Re: 3D-Object invisible after Calibration

Postby franz » Mon Jul 17, 2017 10:26 am

What's your error rate ?

MadMapper's calibration is VERY accurate, as it is based on openCV lib,
which is the de-facto standard in the industry.
To calibrate a sphere, you need to set up calibration point very accurately.
If the object disappear, it basically means that there's too much a difference between
- your calibration points
- pose estimation
- physical references

Try calibrating a cube first to get used to MM's calibration.
Note that using a short throw projector will cause problems to the calibration as well.
franz
MadMapper master
 
Posts: 617
Joined: Fri Feb 18, 2005 7:05 pm
Location: Paris, France

Re: 3D-Object invisible after Calibration

Postby TheYouth » Thu Jul 20, 2017 1:15 pm

Error Rate is 100px in the screenshot, after adding the last point the object disappears and error rate is 16.472
I don´t get it... I definitely should do something wrong or MM is unable to calibrate a sphere... Tried many variants....

Here´s the used .obj File: https://www.dropbox.com/s/lbowpwdfc50ew ... h.obj?dl=0
Attachments
Bildschirmfoto 2017-07-20 um 17.11.57.png
Bildschirmfoto 2017-07-20 um 17.11.57.png (164.19 KiB) Viewed 229 times
TheYouth
Member
 
Posts: 15
Joined: Sun May 15, 2016 4:39 pm

Re: 3D-Object invisible after Calibration

Postby franz » Mon Jul 24, 2017 9:51 am

it seems you're just picking random points on the surface of the sphere.
How do you know for sure there's a correspondance between the points you selected in the model
and the real points on your surface ? You don't, because there's no correspondance.
That's why MM cannot calibrate your object.

On a sphere like that there's no visual references, so I doubt you would ever manage to calibrate it.

Do you have a photo of your real object you're trying to map ?
franz
MadMapper master
 
Posts: 617
Joined: Fri Feb 18, 2005 7:05 pm
Location: Paris, France

Re: 3D-Object invisible after Calibration

Postby TheYouth » Mon Jul 24, 2017 11:24 am

Actually only from the finished one with Watchout. This one has 3.5m diameter and five projectors.... But next time I want to do it with MadMapper, this is why I´m trying to figure out how it´s working....

So it seems that I´ve done something wrong like you say...
As I said: I tried many variants in MM to get it to work.. This one was just an example.
On the real sphere we marked the equator and every 45 degree or more to have an optical reference.

So... placing the sphere in MadMapper, rotate it so it fits nearly the real object and then it goes into calibration mode... Placing the reference points where? on the equator? Didn´t worked for me, object disappears...
Attachments
18954891_1457442167610113_143777089460654822_2.jpg
18954891_1457442167610113_143777089460654822_2.jpg (104.35 KiB) Viewed 196 times
TheYouth
Member
 
Posts: 15
Joined: Sun May 15, 2016 4:39 pm

Re: 3D-Object invisible after Calibration

Postby TheYouth » Thu Jul 27, 2017 10:40 pm

So, any advice? :-)
TheYouth
Member
 
Posts: 15
Joined: Sun May 15, 2016 4:39 pm


Return to MadMapper Support

Who is online

Users browsing this forum: No registered users and 1 guest