Live input from a webcam keeps getting disconnected
  • AgentD
    member
    Posts: 39
    Joined: Sun Nov 18, 2012 7:19 am

    Live input from a webcam keeps getting disconnected

    by AgentD » Wed Apr 19, 2017 12:52 pm

    Hi all!

    I made the installation with MadMapper where I have the live input from a webcam installed ad part of the installation so that the viewers who stand in front are projected onto one of the objects in the installation. It was very simple to set it up but the problem is that the camera seems to get disconnected (or the live feed goes blank) from time to time with no apparent reason and the only way to get it re-connected is to restart the computer.

    Is there anyway that I can change some setting so that the connection stays solid and doesn't lose the live input? If you have any idea or solution to this please share with me. I really appreciate it. Thanks a bunch in advance!

    Screen Shot 2017-04-19 at 6.43.48 AM.png
    Screen Shot 2017-04-19 at 6.43.48 AM.png (139.58 KiB) Viewed 950 times

    Screen Shot 2017-04-19 at 6.43.59 AM.png
    Screen Shot 2017-04-19 at 6.43.59 AM.png (14.73 KiB) Viewed 950 times


    m
  • mad-matt
    garageCube team
    Posts: 343
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Live input from a webcam keeps getting disconnected

    by mad-matt » Thu Apr 20, 2017 10:27 am

    There's no reason why the camera would disconnect...
    Are you running a licenced version or demo version ?
    How long does it take before it disconnects ? Does it happen if opening the camera in QuickTime player and letting it run ?
  • AgentD
    member
    Posts: 39
    Joined: Sun Nov 18, 2012 7:19 am

    Re: Live input from a webcam keeps getting disconnected

    by AgentD » Thu Apr 20, 2017 7:38 pm

    Hi Matt,

    Thank you for your response. Yes, I am using the latest version with the license. Sometimes it gets disconnected within a few hours and sometimes it's Ok for one whole day. And another issue I have is that once it gets disconnected I can't re-connect it unless I restart the computer.

    What do you mean by opening it with Quicktime? While Madmapper is open you open the camera live feed in Quicktime player?

    m
  • mad-matt
    garageCube team
    Posts: 343
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Live input from a webcam keeps getting disconnected

    by mad-matt » Fri Apr 21, 2017 10:32 am

    No, maybe the driver of your device is buggy, so testing with another application than MadMapper will move the problem outside MadMapper ;-)
    So if the camera runs with QuickTime player for a few days, you would know that the problem is not with the driver.
  • AgentD
    member
    Posts: 39
    Joined: Sun Nov 18, 2012 7:19 am

    Re: Live input from a webcam keeps getting disconnected

    by AgentD » Tue Apr 25, 2017 12:51 am

    Oh, I see what you mean... The thing is that the camera worked straight out of box so I didn't install anything. I will look for the webcam';s driver and test it again.

    Thanks!

    AgentD
  • mad-matt
    garageCube team
    Posts: 343
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Live input from a webcam keeps getting disconnected

    by mad-matt » Tue Apr 25, 2017 2:07 pm

    Maybe it's just standard and doesn't need driver. In any case checking if it also crashes after a long time in QuickTime would help determining where the issue comes from
  • AgentD
    member
    Posts: 39
    Joined: Sun Nov 18, 2012 7:19 am

    Re: Live input from a webcam keeps getting disconnected

    by AgentD » Thu Apr 27, 2017 4:38 pm

    I googled and it uses only the generic driver so there is no specific driver provided by Microsoft. I tested it with Quicktime and it has been stable with no issue.

    The thing is that the camera itself works and it runs without any issue with facetime, photobooth, QT etc. The only issue is that in the camera input disappears in the quad in Madmapper.

    I am completely puzzled with this... Any thoughts or suggestions will be highly appreciated.

    Thanks again. AD
  • mad-matt
    garageCube team
    Posts: 343
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Live input from a webcam keeps getting disconnected

    by mad-matt » Fri Apr 28, 2017 11:19 pm

    Is it a licensed version of MM ? demo ?
    Can you send us the log ? (Cmd+click on MM Tools menu => "Enable Log", then start MM, reproduce the issue, then Tools menu => "Send current log")
  • AgentD
    member
    Posts: 39
    Joined: Sun Nov 18, 2012 7:19 am

    Re: Live input from a webcam keeps getting disconnected

    by AgentD » Tue May 23, 2017 10:05 pm

    Yes, it's a licensed and the latest version. I think I figured it out what the issue was. I was using facetime to access the camera as well and it seems like facetime refreshes the connection to the webcam and that kicks the Madmapper connection out.

    Thanks again!

Who is online

Users browsing this forum: No registered users and 3 guests