M8 Compositing handles alpha values poorly
  • geoffmatters
    activ8 member
    Posts: 79
    Joined: Fri Sep 29, 2017 3:29 am

    M8 Compositing handles alpha values poorly

    by geoffmatters » Fri May 17, 2019 2:11 pm

    RGB values of pure white over solid pure white should render to pure white regardless of the alpha values of the upper layer.

    However in M8 a pixel which is RGBA 255,255,255,127 will render grey when composited over white.

    Attached is an example showing a PNG with white shapes with antialiased edges over a solid white layer. M8 renders it with a dark outline. Photoshop renders the same thing as pure white.
  • geoffmatters
    activ8 member
    Posts: 79
    Joined: Fri Sep 29, 2017 3:29 am

    Re: M8 Compositing handles alpha values poorly

    by geoffmatters » Fri May 17, 2019 2:14 pm

    I can't attach anything because "Sorry, the board attachment quota has been reached."
  • geoffmatters
    activ8 member
    Posts: 79
    Joined: Fri Sep 29, 2017 3:29 am

    Re: M8 Compositing handles alpha values poorly

    by geoffmatters » Fri May 17, 2019 2:22 pm

    Repros with 2.92 as well as latest 3.0 on my MBP with AMD Radeon R9 M370X 2048 MB
  • geoffmatters
    activ8 member
    Posts: 79
    Joined: Fri Sep 29, 2017 3:29 am

    Re: M8 Compositing handles alpha values poorly

    by geoffmatters » Sun Jun 14, 2020 8:16 am

    Here is white composition over white resulting in grey pixels.
    It is quite bad that the basic math of compositing layers is not correct. I had been bothered by strange shadows and edges many times over the years, probably as the result of this bug.
    Attachments
    M8 Compositing Bug.png
    M8 Compositing Bug.png (240.71 KiB) Viewed 72 times

Who is online

Users browsing this forum: No registered users and 3 guests