Page 1 of 1

MiniMad not playing recorded animations

Posted: Tue Feb 05, 2019 6:51 pm
by daecarson
Greetings-
I am having a new issue with recording to my MiniMad from MadMapper, as it simply isnt working!

I am on a Mac, my workflow is MadMapper > Advatek PixLite 16 MkII Plug and Play > LEDs. Everything works fine when I have the network cable plugged directly into my mac, I can cycle through animations, I can play a recorded MiniMad animation from the dialog window, however as soon as I export to the MiniMad itself and connect it to the network cable nothing happens even when unplugging/re-plugging. I am having this similar problem working from windows to Minimad, in this instance I was working from Windows MadMapper > PixLite 4 MkII ECO. Both MadMapper applications are the 3.6.5 versions and am wondering if I need to revert back to an older version, as I didn't run into this problem at all when I had baked animations to a MiniMad in November of this last year.

Any insight into why this could be occurring would be great! There are some screengrabs from my tests here:https://photos.app.goo.gl/UUJvxz7zBcJoJ5DH6.

Re: MiniMad not playing recorded animations

Posted: Thu Feb 07, 2019 2:48 am
by jasonbeyers
I had the exact same problem, but with a Pixlite 4 MKII, and I reported it to Garagecube support. Connecting the miniMad directly to the Pixlite simply does not work, regardless of the DNS settings I defined for the MiniMad or the settings on the Pixlite (I tried dozens of combos of all settings).

My solution was to place a network switch between the miniMad and the Pixlite, and things suddenly started working. Based on Advatek's Pixlite manual, I got a switch with IGMP support, specifically this one: https://www.amazon.com/gp/product/B07BN ... UTF8&psc=1

Connecting the miniMad and Pixlite to the same network switch solved my issue. But it would be nice if I didn't have to do that..

P.S. The MiniMad documentation should probably make a note about Advatek controllers

Re: MiniMad not playing recorded animations

Posted: Thu Feb 07, 2019 11:13 am
by Pierre Guilluy
Directly connecting a PixLite and a miniMAD works as long as you manually configured both devices to the same IP-range & netmask.

Is your switch connected to a local network with a DHCP router?

Re: MiniMad not playing recorded animations

Posted: Tue Feb 12, 2019 9:30 pm
by jasonbeyers
Indeed, I did set the Pixlite and MiniMAD with the same IP address range and subnet mask, I still can't get it to work with a direct connection. I've tested a regular cat6 ethernet cable and a patch cable, no luck.

Direct connection with miniMAD and other Artnet controllers/fixtures works just fine. Direct connection from my Mac and the Pixlite also works just fine, using the very same cables.

Placing a network switch in the middle fixed things for MiniMAD+Pixlite. No router was involved in any of these tests, as I was aiming for the simplest and most reliable wiring possible.