FFmpeg Tools is required - after installed?
  • User avatar
    broken
    super8 member
    Posts: 113
    Joined: Sun Dec 23, 2012 11:44 pm
    Location: canada

    FFmpeg Tools is required - after installed?

    by broken » Tue Sep 27, 2016 5:13 pm

    Just picked up my miniMAD and tried to export a quick test map from Madmapper 2.5b5

    It throws up a dialog saying:

    "FFmpeg Tools is required to export to miniMAD.
    Would you like to download it now?"
    NO/YES

    Selecting YES to download, chrome opens, I download the pkg installer, run it..

    Relaunch Madmapper.. Export to miniMAD and I get the same dialog asking if I want to download FFmpeg Tools..

    Knowing that I just installed FFmpeg Tools from the Garagecube website, I figure I might need a reboot before it can find FFmpeg Tools..

    Nope.. same issue. Can't export because it keeps asking me if I want to download FFmpeg Tools.

    Playing back 1 clip in Madmapper it says Player: FFMPEG Player

    Not sure why Madmapper keeps on asking.. Anyone have a clue?

    Yosemite 10.10.5 hackintosh
  • User avatar
    broken
    super8 member
    Posts: 113
    Joined: Sun Dec 23, 2012 11:44 pm
    Location: canada

    Re: FFmpeg Tools is required - after installed?

    by broken » Tue Sep 27, 2016 5:39 pm

    Not sure whats up with the pkg installer.

    After a few google searches on how to manually install FFmpeg, I stumbled upon Homebrew - a terminal package manager for OSX

    http://brew.sh/index.html

    installed via terminal command: /usr/bin/ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homeb ... er/install)"

    then ran: brew install ffmpeg --with-tools

    Problem solved, and the Export dialog pops up instead of MM asking if I want to download FFmpeg constantly.

    Cheers
  • emilesteginga
    junior Member
    Posts: 7
    Joined: Thu Feb 23, 2012 8:19 pm
    Location: Rotterdam
    Contact:

    Re: FFmpeg Tools is required - after installed?

    by emilesteginga » Sun Oct 23, 2016 3:50 pm

    I have the same issue with the latest version of madmapper.

    I tried the homebrew you described but that did not work.
    How to proper install FFmpeg Tools? anyone?

    / edit: finally it did work by using the instructions on this page:
    https://trac.ffmpeg.org/wiki/CompilationGuide/MacOSX
  • Pierre Guilluy
    garageCube team
    Posts: 113
    Joined: Mon Oct 12, 2015 1:50 pm

    Re: FFmpeg Tools is required - after installed?

    by Pierre Guilluy » Thu Oct 27, 2016 10:23 am

    Please check the existence of ffmpeg binaries in /usr/local/bin/ through the terminal:
    # ls /usr/local/bin/ff*

    If the FFmpeg installation went well, you should have:
    /usr/local/bin/ffmpeg
    /usr/local/bin/ffplay
    /usr/local/bin/ffprobe
    /usr/local/bin/ffserver

    If those files are missing, MadMapper will keep asking for FFmpeg binaries installation.

Who is online

Users browsing this forum: No registered users and 1 guest