AVF decoder janky interactions, turns to solid colors
  • geoffmatters
    activ8 member
    Posts: 55
    Joined: Fri Sep 29, 2017 3:29 am

    Re: AVF decoder janky interactions, turns to solid colors

    by geoffmatters » Fri Sep 14, 2018 5:00 am

    I tried the simple repro with 3.0 final release, and can't repro anymore.
    Looks great so far!!
  • geoffmatters
    activ8 member
    Posts: 55
    Joined: Fri Sep 29, 2017 3:29 am

    Re: AVF decoder janky interactions, turns to solid colors

    by geoffmatters » Sat Sep 22, 2018 5:13 am

    Had this problem with official 3.0 release in the context of a real project with lots of media of different formats in different layers.

    Switched a clip from FFMPEG to AVF, but it got stuck in the "loading" state forever, so I switched it back to FFMPEG. Rendered as solid color (based on pixel content) *and* some of the other layers with different clips that I hadn't touched also got corrupted and started rendering as solid colors (each in a color based on that clip's pixel content)

    Over in the support forum there is a post about "clip never shows up unless I switch from one decoder to the other and back again" which I strongly suspect is a related issue.
  • geoffmatters
    activ8 member
    Posts: 55
    Joined: Fri Sep 29, 2017 3:29 am

    Re: AVF decoder janky interactions, turns to solid colors

    by geoffmatters » Sat Sep 22, 2018 5:20 am

    Layer 6 was playing with poor performance, so I switched from FFMPEG to AVF. Layers 3,4,5 which were FFMPEG decoder started rendering as solid colors. I restarted M8 and the issue still persisted! (note that there were VTDecoderXPCService processes hanging around across restart). I switched layer 6 to FFMPEG, and now 3,4,5,6 all render as solid colors. I restart M8 again and after restart they render correctly.

    mid-2015 macbook pro AMD Radeon R9 M370X 2048 MB

    Decoder-related issues have been cropping up since many months ago and I really worry whether I can rely on 3.0

Who is online

Users browsing this forum: No registered users and 1 guest