Modul8 v3.0 hd BETA

Modul8 v3 HD beta program

Moderator: Garagecube

Modul8 v3.0 hd BETA

Postby boris » Fri Jul 29, 2016 7:51 pm

The Modul8 v3.0 hd Beta 1 is released!

Please feel free to use this topic to give us feedback and bug report about the modul8 v3 BETA.
You can send a mail to : beta[AT]garagecube[DOT]com

I will send a beautiful modul8 t-shirt to anybody how report and explain how to reproduce a bug or crash (if the issue is new for us).

Enjoy !
Boris.


PLEASE NOTE :
The team will be on vacation until August 22.
Please continue to send your reports!
We will work hard on it to fix everything (and make t-shirts) when we will back from our holidays.
Thanks for you understanding!


GarageCube and Modul8 Team is proud to announce the release of modul8 HD Public beta 1 Release.
Modul8 goes now HD ! The dev team wrote a brand new media player engine, it's fast, very fast and now Modul8 HD can now render up to 8K videos. Forget about Quicktime PhotoJPEG , this new engine was optimized for HAP and H264 codecs.
We also added useful new features to add comfort for the user experience like a new User interface now compatible with retina display screens. You can now lock a layer to prevent from deleting or editing an important asset of your show.
Up to 1024 Media
New 8 Media set groups : you can now handle up to 1024 media in a single project.
Additional specials testcards: FullHD, HDReady, XGA, WXGA
Output Lightness
Useful when you work with LED Walls or create content for MadMapper's MADLIGHT
Change the brightness of the final displayed output while you keep the output preview untouched

Modul8 HD Version V3.0
BETA 1 Release Note :


NEW FEATURES & CHANGES
+ New super optimized media player engine
(images, movies, image folders, Quartz-Composer, video-inputs)
Now supports videos up to 8K
Optimized for HAP code and H264 video playback

+ user-interface with retina displays support
+ support up to 1024 media loaded (8 mediasets of 128 medias)
+ new Locking and unlocking layer
+ new Master Lightness output
+ new layer normalize ratio options (4/3,16/9,16/10)
+ new automatic Image resizing to use less memory "Image maximum rendering size" preference
+ additional specials testcards: FullHD, HDReady, XGA, WYGA
+ display RGB Color preview for background color, invert output color and output add color, modulate and additive color for layers

IMPROVEMENT

* improved Direct to Disk Recording (faster, add feedback informations)
* Saves video Preview mode when quit.
* video capture preferences display BlackMagic out-dated drivers warning
* Disable Blackmagic support" preference for other apps to use it
* replaced quicktime player by both FFmpeg and AVFoundation for maximum codec compatibility (for multi audio channel video, use AVFoundation playback option)
* bug fixes and stability improvements
*Drag and Drop Media import is working with more than 16 media

New Modul8 Module Keywords:
ctrl_layer_lock
ctrl_layer_mediaSetGroup
ctrl_layer_scale_normalizeOn
ctrl_master_lightness
ctrl_master_fadeToBlack

This Public Beta version is available from today for any users who own a serial which is compatible with modul8 2.9. To download it, click on the button or log on the modul8 yourspace page us gin your modul8 serial

DOWNLOAD MODUL8 HD BETA 1
Please test it and send us your feedback and Bug report to support@garagecube.com
Your feedback is really important in order to improve our Software and provide you the best user experience with Modul8.

All the GarageCUBE/Modul8 team is grateful for your help.


WARNING!! : PLEASE DON'T USE IT IN PRODUCTION (OR AT YOUR OWN RISK)
If you save older project with this beta version you won't be able to open it on version 2.9.2 and older
Last edited by boris on Mon Sep 26, 2016 1:12 pm, edited 6 times in total.
Reason: disclaimer about beta use
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Fri Jul 29, 2016 8:22 pm

I found the 1st issue :
The module 'syphon input' does not choose the correct media!
I new t-shirt for my collection!
;-)
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Fri Jul 29, 2016 8:37 pm

It's fixed there is a new version (1.1) in the online library.
boris wrote:I found the 1st issue :
The module 'syphon input' does not choose the correct media!
I new t-shirt for my collection!
;-)
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby anomad » Fri Jul 29, 2016 8:42 pm

. the beta crashes when I launch on a MacPro 1,1 (original model) 12GB RAM, OS X 10.7.5 - what is the minimum supported hardware / OS level ? :)
anomad
master
 
Posts: 411
Joined: Sun Oct 21, 2007 10:07 pm
Location: north cakalacky, usa

Re: Modul8 v3.0 hd BETA

Postby mocomeau » Fri Jul 29, 2016 9:05 pm

There seems to be a problem with the Syphon Module.

If I syphon out Modul8 to MadMapper, it seems to take a larger part then what I am sending.

For instance, if I'm outputting 720p, if I do a simple "Full Screen" output, it goes full. If I output it to syphon and Madmapper, it will take a bigger chunk of output. If I move my image in modul8, I can see it move in the dead space in Madmapper. As if the syphon took larger than it was suppose to.

The cropping of mad mapper doesn't work because there is a massive lost of resolution.

I'm attaching a picture. I hope this issue could be fixed soon because I would love to test it on the road !

** When troubleshoot with modul8 2.9, Syphon takes the full resolution
Attachments
Capture d’écran 2016-07-29 à 15.02.06.png
Madmapper_Syphon Windo
Capture d’écran 2016-07-29 à 15.02.06.png (116.79 KiB) Viewed 4102 times
mocomeau
Junior Member
 
Posts: 1
Joined: Fri Jul 29, 2016 8:59 pm

Re: Modul8 v3.0 hd BETA

Postby rdpozo » Sat Jul 30, 2016 12:07 am

Seems to be very jittery when playing back hap encoded video files. Tried different hap codecs. jitters/stops in playback.
Same files work fine on 2.9
rdpozo
Junior Member
 
Posts: 3
Joined: Thu Jun 30, 2016 8:18 am

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 12:59 am

Oh oh!
Already some issues!
I think I will do more t-shirt than expected!
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 1:14 am

AAScreen Shot 2016-07-30 at 01.08.42 copy.png
AAScreen Shot 2016-07-30 at 01.08.42 copy.png (1.04 MiB) Viewed 4034 times
Hi mocomeau,
Are you sure that your preferences are well adjusted?
The preferences for the 3.0 are not the same file of the 2.9.xxx, maybe by default is too high, I will check.
I tested on my computer and it's fine (see the screenshot).

Boris.



mocomeau wrote:There seems to be a problem with the Syphon Module.

If I syphon out Modul8 to MadMapper, it seems to take a larger part then what I am sending.

For instance, if I'm outputting 720p, if I do a simple "Full Screen" output, it goes full. If I output it to syphon and Madmapper, it will take a bigger chunk of output. If I move my image in modul8, I can see it move in the dead space in Madmapper. As if the syphon took larger than it was suppose to.

The cropping of mad mapper doesn't work because there is a massive lost of resolution.

I'm attaching a picture. I hope this issue could be fixed soon because I would love to test it on the road !

** When troubleshoot with modul8 2.9, Syphon takes the full resolution
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 1:29 am

Hi rdpozo, can you elaborate a bit?
Your version of OSX, your computer ? (ram, graphic card, hard drive...)
On my not so new Mac Book Pro Retina (middle 2012, 2.3 Ghz i7, 8GB ram, Nvidia GeForce GT 650M 1024MB, SSD disk) and OSX 10.11 it works like a charm...

rdpozo wrote:Seems to be very jittery when playing back hap encoded video files. Tried different hap codecs. jitters/stops in playback.
Same files work fine on 2.9
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 1:34 am

I think we did not tested less than 10.9... :-o
Maybe that's the minimum...I will check...
So you win a T-shirt, please send a mail to beta[AT]garagecube[DOT]com with you size !

anomad wrote:. the beta crashes when I launch on a MacPro 1,1 (original model) 12GB RAM, OS X 10.7.5 - what is the minimum supported hardware / OS level ? :)
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 1:37 am

I found a crash when you switch between syphon output and desktop if you use the syphon in MadMapper.
So no t-shirt for this one!
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby boris » Sat Jul 30, 2016 1:44 am

Hi there,

The team will be on vacation until August 22.
But please continue to send your reports !
We will work hard on it to fix everything (and make t-shirts) when we will back from our holidays.

Thanks for your understanding !
Boris.
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby niabarreto » Sat Jul 30, 2016 2:39 am

I am testing Modul8 v3.0 on my old mac (mid 2009 15" MacBook pro, 4GB RAM, with 10.11.3 OSX "El Capitan" ) and so far,so good.
I am using touchOSC and have different codecs (some PhotoJPEG and H264), and the iSight. I have to say I just do this for testing purposes and have a 3-4 active layer limitation (due to ram, duh), but everything seems to be working just fine, with luma and tracing on and reproducing sound and everything. I haven't tried syphon yet.
Thanks for the update guys!
niabarreto
Junior Member
 
Posts: 1
Joined: Sat Jul 30, 2016 2:24 am

Re: Modul8 v3.0 hd BETA

Postby rdpozo » Sat Jul 30, 2016 8:41 am

Sure Boris,

Here is the specs:

OSX El Capitan
V. 10.11.5
Macbook Pro (retina 15-inch, Early 2013)
Prosessor 2,8 GHz Intel Core i7
Mem 16 gig 1600 MHz DDR3
Graphics NVIDIA GeForce GT 650M 1024 MB

Hap QT Nr.11
Codec: HAP
Quality: Medium
FPS: 25
Size: 1280 x 720
rdpozo
Junior Member
 
Posts: 3
Joined: Thu Jun 30, 2016 8:18 am

Re: Modul8 v3.0 hd BETA

Postby gmint » Sun Jul 31, 2016 12:16 am

I used the beta for a show last night and noticed a couple of things. Not sure they really qualify as bugs, but it would be nice to see them both fixed in any case.

1) (Not new in this version) The state of the fading and scaling crossfader settings are not saved into a composition across restarts. It would be very nice if they were.

2) If a composition has been saved with modules and those modules are missing (which they were from my beta install at first) Modul8 will open the project but it will continue displaying a "Loading Structures" dialog indefinitely.

3) For some reason, all of my HAP encoded files have a strange yellowish tint. This does not seem to be the case when I load the same files in MadMaper. I have attached a screenshot. This does not happen with H.264 or other files.

Screen Shot 2016-07-30 at 5.13.21 PM.jpg
Screen Shot 2016-07-30 at 5.13.21 PM.jpg (221.95 KiB) Viewed 3856 times
User avatar
gmint
ultim8 member
 
Posts: 301
Joined: Wed Aug 04, 2004 4:30 am
Location: Des Moines, IA

Next

Return to Modul8 v3 HD BETA

Who is online

Users browsing this forum: No registered users and 1 guest