Modul8 v3.0 hd BETA

Modul8 v3 HD beta program

Moderator: Garagecube

Re: Modul8 v3.0 hd BETA

Postby Videometry » Tue Aug 30, 2016 8:09 am

Still getting some strangeness in the midi mapping on v3...

I'm just creating a layer, hitting edit midi map, then switching between position and layerset + position modes. The BG Color G + B stay mappable green while red does not (they should all be off?).

If i duplicate the blank layer a few times and then re-enter the mapping mode in position or layerset modes those ghost boxes re-appear... Are you able to reproduce? Let me know if you need any info on my system-

Thanks!
Attachments
Screen Shot 2016-08-30 at 2.00.20 AM.png
weird mapping parameters
Screen Shot 2016-08-30 at 2.00.20 AM.png (244.64 KiB) Viewed 1632 times
Videometry
Member
 
Posts: 18
Joined: Mon Oct 29, 2012 5:48 pm

Re: Modul8 v3.0 hd BETA

Postby pele2010 » Sun Sep 04, 2016 5:26 pm

( how I would love a way to import vector shapes directly, without converting them to bitmaps ; - )[/quote]


me too!

it saves so much time!

thanks peter
pele2010

Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
accomplish the great task by a series of small acts.
http://www.eachfilm.de /// each01
User avatar
pele2010
ultim8 member
 
Posts: 262
Joined: Sat Apr 10, 2010 8:16 pm
Location: Hamburg, Germany

Re: Modul8 v3.0 hd BETA

Postby sir.phit » Sun Sep 11, 2016 3:11 am

crashes on open, this is the apple report it gives me.

Process: launchd [3119]
Path: /Applications/Modul8/Modul8.app/Contents/MacOS/Modul8
Identifier: com.GarageCUBE.modul8-30
Version: ??? (???)
Code Type: X86 (Native)
Parent Process: launchd [128]

Date/Time: 2016-09-09 23:26:04.225 -0700
OS Version: Mac OS X 10.7.5 (11G63)
Report Version: 9

Interval Since Last Report: 352140 sec
Crashes Since Last Report: 4
Per-App Crashes Since Last Report: 4
Anonymous UUID: 5EBEFDBE-4FD8-4142-BD5E-F9891BDBAA4B

Crashed Thread: Unknown

Exception Type: EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x000000008fe01030

Backtrace not available

Unknown thread crashed with X86 Thread State (32-bit):
eax: 0x00000000 ebx: 0x00000000 ecx: 0x00000000 edx: 0x00000000
edi: 0x00000000 esi: 0x00000000 ebp: 0x00000000 esp: 0x00000000
ss: 0x00000023 efl: 0x00010202 eip: 0x8fe01030 cs: 0x0000001b
ds: 0x00000023 es: 0x00000023 fs: 0x00000000 gs: 0x00000000
cr2: 0x8fe01030
Logical CPU: 4

Binary images description not available


External Modification Summary:
Calls made by other processes targeting this process:
task_for_pid: 1
thread_create: 0
thread_set_state: 0
Calls made by this process:
task_for_pid: 0
thread_create: 0
thread_set_state: 0
Calls made by all processes on this machine:
task_for_pid: 4089
thread_create: 1
thread_set_state: 0

Model: MacPro3,1, BootROM MP31.006C.B05, 8 processors, Quad-Core Intel Xeon, 2.8 GHz, 4 GB, SMC 1.25f4
Graphics: ATI Radeon HD 5870, ATI Radeon HD 5870, PCIe, 1024 MB
Memory Module: DIMM Riser B/DIMM 1, 2 GB, DDR2 FB-DIMM, 800 MHz, 0x0000, 0x000000463732353642363145353830304600
Memory Module: DIMM Riser A/DIMM 1, 2 GB, DDR2 FB-DIMM, 800 MHz, 0x0000, 0x000000463732353642363145353830304600
AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x87), Atheros 5416: 2.1.14.9
Bluetooth: Version 4.0.8f17, 2 service, 18 devices, 1 incoming serial ports
Network Service: Ethernet 2, Ethernet, en1
PCI Card: ATI Radeon HD 5870, sppci_displaycontroller, Slot-1
PCI Card: ATI Radeon HD 5870, ATY,LangurParent, Slot-1
Serial ATA Device: WDC WD10EAVS-00D7B1, 1 TB
Serial ATA Device: Samsung SSD 850 EVO 250GB, 250.06 GB
Serial ATA Device: SanDisk SDSSDHII480G, 480.1 GB
Parallel ATA Device: PIONEER DVD-RW DVR-112D
USB Device: Keyboard Hub, apple_vendor_id, 0x1006, 0xfd200000 / 2
USB Device: Apple Keyboard, apple_vendor_id, 0x0220, 0xfd220000 / 3
USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8206, 0x5d200000 / 3
USB Device: Dynex 5-Button Wired Optical Mouse, 0x0461 (Primax Electronics), 0x4d42, 0x5d100000 / 2
sir.phit
Member
 
Posts: 10
Joined: Sun Feb 27, 2011 3:59 am

Re: Modul8 v3.0 hd BETA

Postby boris » Wed Sep 28, 2016 7:38 pm

Good news, I found the way to reproduce it and it's fixed now for the next upcoming Beta (release planned tomorrow).
You definitely win a t-shirt :-)

Boris.

Videometry wrote:Still getting some strangeness in the midi mapping on v3...

I'm just creating a layer, hitting edit midi map, then switching between position and layerset + position modes. The BG Color G + B stay mappable green while red does not (they should all be off?).

If i duplicate the blank layer a few times and then re-enter the mapping mode in position or layerset modes those ghost boxes re-appear... Are you able to reproduce? Let me know if you need any info on my system-

Thanks!
Boris * GarageCUBE team
User avatar
boris
GarageCUBE team
 
Posts: 888
Joined: Mon Jun 28, 2004 12:36 am
Location: Geneva

Re: Modul8 v3.0 hd BETA

Postby Pierre Guilluy » Thu Sep 29, 2016 2:08 pm

@VJFranzK

The problem you experience with your alpha PNG seems to be due the its odd number of lines (1920x1893).

I could reproduce the same problem in MadMapper and other concurrent softwares as well.

From what I can see, the image is fully-white with a alpha mask that defines the rounded shape.

It seems like such an image confuses the OpenGL drivers which produces a texture with a correct Alpha channel, but messed up RGB channels.

Resizing the image to an even number of lines fixes the problem.

Pierre

Screen Shot 2016-09-29 at 13.27.28.png
Screen Shot 2016-09-29 at 13.27.28.png (223.92 KiB) Viewed 1486 times
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Re: Modul8 v3.0 hd BETA

Postby Pierre Guilluy » Thu Sep 29, 2016 6:11 pm

@VJFranzK again

After further testing, I'm not sure the problem comes from OpenGL rendering, because I've been able to produce a transparent PNG with the exact same size that doesn't produce the same issue.

What software did you use to export your image?
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Previous

Return to Modul8 v3 HD BETA

Who is online

Users browsing this forum: No registered users and 1 guest