SUB works like ADD
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    SUB works like ADD

    by pele2010 » Thu Oct 27, 2016 11:52 am

    Hi,

    since the beta1 I am having the problem, that the "sub blending" mode is not working like it used to be.

    If a layer was above another layer and was "sub'ed" it used to subtract information from the layer below.
    In the M8 3 Beta it´s adding information to the layer.

    So if you feedback loops you can´t play with the "sub" blending mode anymore.
    You need to use "exc" but it works different to the "sub" blending mode.

    Does someone have the same problems?

    best peter
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • Pierre Guilluy
    garageCube team
    Posts: 128
    Joined: Mon Oct 12, 2015 1:50 pm

    Re: SUB works like ADD

    by Pierre Guilluy » Thu Oct 27, 2016 4:37 pm

    Here's the simplest example I could make (testcard as a background and a white square on top) trying to replicate your problem:

    ADD

    v3
    M8_V3_ADD.png
    M8_V3_ADD.png (419.01 KiB) Viewed 1482 times


    v2
    M8_V2_ADD.png
    M8_V2_ADD.png (290.2 KiB) Viewed 1482 times


    SUB

    v3
    M8_V3_SUB.png
    M8_V3_SUB.png (413.06 KiB) Viewed 1482 times


    v2
    M8_V2_SUB.png
    M8_V2_SUB.png (287.47 KiB) Viewed 1482 times


    EXC

    v3
    M8_V3_EXC.png
    M8_V3_EXC.png (424.4 KiB) Viewed 1482 times


    v2
    M8_V2_EXC.png
    M8_V2_EXC.png (296.69 KiB) Viewed 1482 times


    I can't see any difference between version 2 and 3 regarding the way the blending mode works.

    Couldn't it be some running module that messes with the blending on either version?
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    Re: SUB works like ADD

    by pele2010 » Thu Oct 27, 2016 5:33 pm

    Hi Pierre,

    that was always my problem , that my experience differs from the others!

    from top to bottom

    add
    sub
    premult
    scr
    exc

    here you can see that only "SCR" and "EXC" are like they used to be ...


    ADD_SUB.jpg
    ADD_SUB.jpg (43.72 KiB) Viewed 1474 times
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    Re: SUB works like ADD

    by pele2010 » Thu Oct 27, 2016 5:41 pm

    and her the screenshots itself

    add
    add.jpg
    add
    add.jpg (79.98 KiB) Viewed 1474 times


    sub
    sub.jpg
    sub
    sub.jpg (76.92 KiB) Viewed 1474 times


    premult
    premult.jpg
    premult
    premult.jpg (78.87 KiB) Viewed 1474 times
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    Re: SUB works like ADD

    by pele2010 » Thu Oct 27, 2016 5:42 pm

    and

    SCR
    SCR.jpg
    SCR
    SCR.jpg (82.03 KiB) Viewed 1474 times


    EXC
    EXC.jpg
    EXC
    EXC.jpg (93.39 KiB) Viewed 1474 times
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    Re: SUB works like ADD

    by pele2010 » Thu Oct 27, 2016 5:44 pm

    And the question was:

    can it be the graphic card I am using?

    Bildschirmfoto 2016-10-27 um 17.44.45.png
    Bildschirmfoto 2016-10-27 um 17.44.45.png (44.46 KiB) Viewed 1474 times
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • Pierre Guilluy
    garageCube team
    Posts: 128
    Joined: Mon Oct 12, 2015 1:50 pm

    Re: SUB works like ADD

    by Pierre Guilluy » Mon Oct 31, 2016 11:58 am

    Hi Peter,

    Thanks for sending the graphic-card model you're using:
    I just ran my tests again but forcing the integrated Iris GPU this time instead of the discrete one and I can reproduce your problem.

    I will now go through a debug session and let you know.

    Pierre
  • User avatar
    pele2010
    ultim8 member
    Posts: 262
    Joined: Sat Apr 10, 2010 8:16 pm
    Location: Hamburg, Germany
    Contact:

    Re: SUB works like ADD

    by pele2010 » Mon Oct 31, 2016 12:03 pm

    Puh,

    I thought I was getting crazy ....

    thanxs Peter
    pele2010

    Act without doing; work without effort. Think of the small as large and the few as many. Confront the difficult while it is still easy;
    accomplish the great task by a series of small acts.
    http://www.eachfilm.de /// each01
  • Pierre Guilluy
    garageCube team
    Posts: 128
    Joined: Mon Oct 12, 2015 1:50 pm

    Re: SUB works like ADD

    by Pierre Guilluy » Mon Oct 31, 2016 1:23 pm

    I've just check and I have the exact same result using Modul8 2.9.2.

    Anyways I've just found the bug and the fix will be available in the next beta!

    Pierre

Who is online

Users browsing this forum: No registered users and 2 guests