Loops still glitching.

Modul8 v3 HD beta program

Moderator: Garagecube

Loops still glitching.

Postby morph » Wed Nov 16, 2016 12:55 pm

Running Beta 5 and still getting glitching when clips loop. I noticed this in earlier betas but the release notes said it had been fixed.
morph
activ8 member
 
Posts: 50
Joined: Mon Mar 21, 2011 12:20 pm

Re: Loops still glitching.

Postby Pierre Guilluy » Thu Nov 17, 2016 9:29 am

We made a lot of improvements regarding trigger time, looping and video player performance since the first beta.

Could you send an example of video file that doesn't loop correctly on your side?
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Re: Loops still glitching.

Postby morph » Mon Jan 09, 2017 6:35 am

Updated my verion of the HAP codec and looping seems alot better now
morph
activ8 member
 
Posts: 50
Joined: Mon Mar 21, 2011 12:20 pm

Re: Loops still glitching.

Postby Pierre Guilluy » Tue Jan 10, 2017 1:10 pm

The HAP codec for AVFoundation Player is embedded into Modul8's bundle.

How did you update your codec?
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Re: Loops still glitching.

Postby broken » Wed Mar 08, 2017 9:33 pm

Having lots of issues with HAP and some glitches with PhotoJPEG.. both when looping.

Tried to create a video to compare playback on CoGe using HAP/PhotoJpeg of the same clip vs Modul8 HAP/PhotoJpeg but trying to get the file size down compressed it too much to tell what was the glitching part.

Here's a dropbox link of 2 of the same clips - one HAP encoded, and one PhotoJpeg.. https://www.dropbox.com/sh/fe380x0qbmmv ... ooR8a?dl=0

The HAP one glitches really bad on looping in the beta8 - PhotoJpeg there's some stuttering, doesn't look as bad. In CoGe you'd really have to pay close attention to notice any issue on either clip.

Happy to test or provide more info.. Really want things to be smooth as silk ;) I don't think my computer is struggling to handle the content.

6gb GTX 780, 32gb ram, i7, 10.10.5
User avatar
broken
super8 member
 
Posts: 112
Joined: Sun Dec 23, 2012 11:44 pm
Location: canada

Re: Loops still glitching.

Postby morph » Tue Mar 28, 2017 5:09 am

Just about to post a new post with the glitching issues I'm having
morph
activ8 member
 
Posts: 50
Joined: Mon Mar 21, 2011 12:20 pm

Re: Loops still glitching.

Postby Pierre Guilluy » Fri Mar 31, 2017 12:45 pm

Modul8 3.0 Beta 9 comes with AVFoundation Player looping improvements:
http://forum.garagecube.com/viewtopic.php?f=41&t=9820
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Re: Loops still glitching.

Postby broken » Mon Apr 03, 2017 8:38 pm

Pierre Guilluy wrote:Modul8 3.0 Beta 9 comes with AVFoundation Player looping improvements:
http://forum.garagecube.com/viewtopic.php?f=41&t=9820


This new update seems to have dramatically improved looping for the clips I linked in my previous post. The HAP encoded clip loops with almost no glitching at all. With a few layers blended, that slight glitch may be even harder to detect.

Appreciate it!
User avatar
broken
super8 member
 
Posts: 112
Joined: Sun Dec 23, 2012 11:44 pm
Location: canada

Re: Loops still glitching.

Postby somdara » Sat May 27, 2017 4:22 pm

somdara
Junior Member
 
Posts: 3
Joined: Sat May 27, 2017 1:09 pm

Re: Loops still glitching.

Postby Pierre Guilluy » Mon May 29, 2017 9:35 am

HAP playback occurs thanks to the "HAP in AVFoundation" codec https://github.com/Vidvox/hap-in-avfoundation that's built in the application.
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm

Re: Loops still glitching.

Postby braquage » Mon Jun 12, 2017 10:22 pm

Dear Modul8,

I installed beta 12 and I now have some stuttering problems with playback in loop mode.
It occurs for videos played with ffmpeg (png, pjpeg and h264).
For testing, I rendered a video with AE CC 2017 in all formats mentioned above and also in hap format which is ok.

Videos are available here (only for 7 days)

https://wetransfer.com/downloads/65a467c4a6e3c620cf1cf8fee099fd9d20170612201642/0d38fe051d6a1826bcf1df03976aed5d20170612201642/06c714

Hope stuttering issue will be solve in next beta. I don't want to re-render all my loops...

Braquage
braquage
Junior Member
 
Posts: 4
Joined: Fri Jul 17, 2009 8:07 pm

Re: Loops still glitching.

Postby Pierre Guilluy » Wed Jun 14, 2017 10:41 am

Thanks for the files, we'll investigate and propose a fix asap.
Pierre Guilluy
GarageCUBE team
 
Posts: 87
Joined: Mon Oct 12, 2015 1:50 pm


Return to Modul8 v3 HD BETA

Who is online

Users browsing this forum: No registered users and 1 guest