3.0 BETA 1 freezes when launched (Win10)

MadMapper Beta program

3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Thu Jun 01, 2017 4:54 pm

Hi all,

I'm new to the forum, so apologies if I'm posting this in the wrong spot...

I got the message about the Windows beta this morning, and it was like Christmas for me! I just bought a new Win10 gaming laptop, after many years on Mac, and one of my biggest concerns was that I would have to leave MadMapper behind. I immediately downloaded the Windows beta, installed it, registered my serial #, and fired it up.

Sadly it won't open - it just hangs on the MadMapper logo screen. Worse, there is no way to close the program - not even by trying to kill the process in Task Manager. I had to reboot my machine.

I realize this is early days, so I'm not complaining - just wanted to report my experience. I would be happy to help out further in the beta testing process - I'm really excited that my favorite mapping software is making the leap to Windows at the same time I am.

cheers,
jeff
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Thu Jun 01, 2017 5:22 pm

Quick update - tried unplugging my external monitor and running it again. This time, the software didn't freeze - it showed the logo screen, then the program quit before opening any windows.

Computer specs:
Win10 Home 64-bit
i7-7700HQ processor
16GB RAM
Nvidia GTX 1060 (6G) graphics

Let me know if there are any log files, etc that I can submit.

cheers,
j
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Thu Jun 01, 2017 8:39 pm

You can right click on MadMapper in Task Manager and choose "Create dump file" in the menu, send send the file to support@garagecube.com specifying "for MM developpers", we'll check that one asap.
Thanks for your report !
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Sat Jun 03, 2017 5:42 pm

It appears that the issue is permissions-related. I enabled the Windows "super administrator" account - see here:
https://www.ghacks.net/2014/11/12/how-t ... r-account/

After logging out of my user account, and then logging in as the newly-enabled "Administrator" user, I was able to open MadMapper successfully.

I already had administrator privileges enabled for my user account, but this is different from the "super administrator" privileges given to the account named "Administrator". Confusing stuff.

I still have not figured out how to give "super administrator" privileges to my user account, so in my mind this is still a bug that needs to be addressed - but I have at least figured out a way to play around with MadMapper on Win10, so at the moment I'm happy :)

- j
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Sun Jun 04, 2017 2:43 pm

I just tested on a clean Windows and have not had this issue with a standard admin account.

But I had first another issue: the app was not starting but I had a "missing dll" message box, I had to install vc2015 redistributables manually, seems the installer just installs vc2013 (or the opposite I don't remember) - msvcrt140 dlls were missing. Hopefully the vc redistributables are installed in MadMapper directory, so if it happens to anyone just install it manually.
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Tue Jun 06, 2017 2:12 am

Thanks for looking into it. It sounds like whatever is going on with my situation isn't easy to replicate - which is good for you guys, but unfortunate for me...

Just to recap my current situation - I installed MadMapper from a Win10 user account that had admin permissions. When I'm logged in under that account, I still can't open MM - the logo screen shows, then the software immediately quits. Trying to "run as admin" from the right-click context menu has no effect.

After I enabled the Win10 "super admin" account and switched to it, I was able to run MadMapper perfectly - it works like a charm.

BUT - when I switch back, it still doesn't work from any other user account. Which sucks, because the rest of my workflow - software, settings, etc. - is tied up in my user account, not the super admin. Trying to manage two user accounts just so I can run MadMapper is a royal pain - and running Windows in superuser mode all the time is a security nightmare.

So, while I am enjoying playing with the new Beta, I still don't have a real long-term solution. I still have a few more tricks to try - I am going to see if doing a full uninstall, then installing MadMapper from the super admin account, solves the issue.

More than anything, I'd like to find out if there are any other users experiencing similar issues. I have had zero problems like this with any other Windows software, ever. I am relatively new to Win10, but I've been a Windows user for over 20 years. The whole thing has been an odd learning experience for me...
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Tue Jun 06, 2017 2:44 am

Also worth noting - I am on Win10 Home, not Win10 Pro...
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Tue Jun 06, 2017 5:46 pm

Yes, a few other people reported this issue. We'll do some testing with Win10 Home asap.

Can you type that in Command Prompt and tell me if after that, running MadMapper from your user account works ?

REG ADD HKCU\SOFTWARE\Garagecube\MadMapper /f /v enableHttpServer /t REG_SZ /d 0

It will disable an HTTP server MadMapper starts internally for the material editor.
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Tue Jun 06, 2017 6:10 pm

Just tried the registry patch - no change on this end, I'm afraid.

One thing did change earlier today, before I tried the registry fix - launching MadMapper from my user account has gone back to locking up the computer, instead of instantly closing. In either case I don't get past the logo screen. Everything still works fine in super admin mode.

- j
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Tue Jun 06, 2017 9:24 pm

Another tought, MadMapper checks for update at startup, you can try disabling it (together with a lot of message boxes, so restore the setting after) by typing that:

REG ADD HKCU\SOFTWARE\Garagecube\MadMapper /f /v silentMode /t REG_SZ /d 1

Does it help ?

To restore both settings in default state:

REG DELETE HKCU\SOFTWARE\Garagecube\MadMapper /v silentMode
REG DELETE HKCU\SOFTWARE\Garagecube\MadMapper /v enableHttpServer
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Wed Jun 07, 2017 4:16 am

Tried this as well, no luck. Keep sending ideas and I will keep testing 'em...
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Wed Jun 07, 2017 9:59 am

We'll make tests with a wider variety of Windows version, including Windows 10 Home, asap. We'll keep you posted. Thanks for your precious feedback!
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Thu Jun 08, 2017 10:19 pm

We could handle this issue, we keep you posted very soon.
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby mad-matt » Fri Jun 09, 2017 7:03 pm

Dear all,
If anyone experienced an authorization issue on Windows, we solved the problem. Here is a new build: http://www.madmapper.com/download/beta/ ... 0_BETA.exe
Let us know if you have any other issue.
It's possible that a invalid machine was authorized with your serial number. If that's the case, send a mail to support[AT]garagecube[DOT]com, we can find out which one is invalid easiely so we'll check and remove this activation.
Thanks for your feedback!
Matthieu - MM team
Last edited by mad-matt on Thu Jun 15, 2017 5:36 pm, edited 1 time in total.
mad-matt
MadMapper master
 
Posts: 293
Joined: Mon Sep 09, 2013 5:50 pm

Re: 3.0 BETA 1 freezes when launched (Win10)

Postby beatfix » Sat Jun 10, 2017 9:12 am

Very pleased to report that I just tested the new beta, and the software has now opened on my normal Win10 user account. Haven't had a chance to fully put it through its paces yet, but it looks like the issue is fixed. Big thanks to the MadMapper team for your responsiveness and excellent customer support.

cheers,
j
beatfix
Member
 
Posts: 10
Joined: Thu Jun 01, 2017 4:46 pm

Next

Return to MadMapper BETA

Who is online

Users browsing this forum: No registered users and 1 guest

cron