MadMapper crashing after 30 minutes of running videos/annimations
  • acronaitor
    junior Member
    Posts: 1
    Joined: Thu Jul 26, 2018 9:56 pm

    MadMapper crashing after 30 minutes of running videos/annimations

    by acronaitor » Wed Aug 01, 2018 5:58 pm

    Hi,

    I am having an issue where MadMapper is crashing consistently after approximately 25-30 minutes of running.
    I am using MadMapper for a touch projection wall at work and need the program to run smoothly indefinitely so any help is very appriciated.

    My setup:
    PC: WIndows 10 pro, i5-7500T, GTX 1060 6gb, 8gb ddr4-2400 memory, 120gb M.2 SATA SSD.
    Outputs: LG 32" 1080 TV as primary monitor, Dell S718QL as the projector.

    Actions to cause crash:
    I have a 15.2mb mp4 video file running on a loop as well as 6 line annimations running on the program. I start these annimations up and set the output to full screen to display the projection through my projector. The program then runs the video and annimations on loop for approximately 25-30 minutes before failing. It does not fail at any particular point in the video playback, it is always at a different point in playback. I also have kept an eye on my hardware usage and do not see any bottlenecking going on. Upon failing the main output/input windows fail and lock up. I cannot navigate my projections/quads nor change anything. For some reason I can still click on control buttons in MadMapper and adjust parameters but it does not translate to the quad on the output screen as the output screen is totally frozen. The only way to fix the issue is to restart MadMapper.

    I have attempted windows updates, driver updates, and reinstalling MadMapper.

    I will eventually be running 2 projectors with 20 or more annimations and videos so I want to ensure stability of the program now while it is still running a very basic test projection.

    Anyone have any ideas?
    Thank you!
  • mad-matt
    garageCube team
    Posts: 590
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: MadMapper crashing after 30 minutes of running videos/annimations

    by mad-matt » Fri Aug 03, 2018 10:33 am

    Hi,

    Another person reported me this issue. MadMapper 3.3.3 was running fine (also available on yourspace). But that makes no sense, we did lot of testing on various hardware letting it run for days without issue.

    Let's try to debug:

    1- Does it also happen with MadMapper 3.5.1 (available now in yourspace) ?
    2- Does it happen with MadMapper Demo version ?
    3- How to reproduce:
    - what if you just start MadMapper, make a quad with a Material ? Does it crash ?
    - if you do the same test but with fullscreen started, does it crash ?

    Best Regards,
    Matthieu - MM team
  • VJ Sun Yat Eye
    junior Member
    Posts: 2
    Joined: Tue Sep 11, 2018 10:40 am

    Re: MadMapper crashing after 30 minutes of running videos/annimations

    by VJ Sun Yat Eye » Tue Sep 11, 2018 11:39 am

    Hi,

    I'm having a similar problem. I have noticed a freezing around 20-30minutes of running. Also, seems to struggle when I'm switching to different visuals... (No matter the size or resolution of the file)
    I tried to fix it by removing automatical programs to open and updating the driver of my graphic card.
    Nothing seems to get better. :(
    If there's any tips or solutions I'll take it !!

    Thanks
  • mad-matt
    garageCube team
    Posts: 590
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: MadMapper crashing after 30 minutes of running videos/annimations

    by mad-matt » Tue Sep 11, 2018 11:53 am

    I had an identical report from a user having an ASUS laptop with an Intel card, and he solved the issue by installing the latest driver ASUS provides for this machine, which was older than the latest from Intel website... (so he kind of downgraded the driver...)
    We have been doing hardcore testing with OpenGL analysis and have not found OpenGL errors in MadMapper, so that should be a driver issue.

    Another user told me he had no issue with MadMapper 3.3.3, but I couldn't get more information. Is 3.3.3 having the same problem on your machine ?

    Another user reported me that the problem was his computer automatically switching GPU after some time, I can't find the ticket and can't remember how he solved it. Do you have two GPUs on your computer ?

    Can you confirm me you're running Windows and a registered version of MadMapper ?
  • VJ Sun Yat Eye
    junior Member
    Posts: 2
    Joined: Tue Sep 11, 2018 10:40 am

    Re: MadMapper crashing after 30 minutes of running videos/annimations

    by VJ Sun Yat Eye » Wed Oct 10, 2018 10:08 am

    Hi,
    Thanks for your reply.
    here is the full details of my PC : ASUS GL552JX-DM394T
    https://www.ldlc.com/fiche/PB00205288.html
    I was wondering also if its not a problem with the type of files (and the amount) that i use, that can b too heavy...?
    I'm going to reinstall the 3.3.3 version to see if it happens again.
    I'll let you know if it works better.
  • mad-matt
    garageCube team
    Posts: 590
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: MadMapper crashing after 30 minutes of running videos/annimations

    by mad-matt » Wed Oct 10, 2018 10:45 am

    Are your graphic drivers up to date ?
    Can you test with MadMapper 3.6.0 beta (available on yourspace)

Who is online

Users browsing this forum: No registered users and 2 guests