MadMapper 4 Beta 7 available
  • Benoit
    super8 member
    Posts: 127
    Joined: Fri Jan 04, 2019 6:42 pm
    Location: Geneva
    Contact:

    MadMapper 4 Beta 7 available

    by Benoit » Mon Feb 17, 2020 5:26 pm

    Dear mappers!

    We are glad to announce that the BETA 7 of MadMapper 4 is available on Yourspace,
    With more and more improvements, although of course we don't advise to use it if you are in production, the version is now (pretty) stable.
    We have received nice feedback on this v4, so don't hesitate to share yours!

    This Beta will expire the 15th of March and is free for v3 owners

    MM 4.0.0 Beta 7 Release Notes

    ADDITIONS
    + Added speed and scratch feature to Audio Player module
    + Added value range in Oscillator module

    IMROVEMENTS
    * miniMAD Video: Improved synchronisation in framebuffer mode
    * Current tab and central panel selection are now saved in the project
    * Windows / ArtNet unicast: improved performance when controlling many ArtNet devices in unicast (especially when some IPs are not available on the network)
    * Better handling of different Blending Modes with media alpha and feathering
    * Improved Code Editor search widget
    * Improved ArtNet unicast fluidity on Windows when some IPs are offline
    * Optimization working with huge number of fixtures & ArtNet unicast items
    * Graphics scene: Alt+click on edited bezier path to insertPoint (like double click)
    * Cmd+A / Ctrl+A in mask/line edition mode selects all edited path handles

    FIXES
    - miniMAD Video: Fixed OSD when the miniMAD is running in framebuffer mode
    - Fixed cueing Audio Player position
    - Fixed support for Blackmagic Web Presenter & ATEM Mini
    - Fixed an issue navigating in previews with a touch pad on Windows
    - Fixed issue rotating a line or mask item
    - Fixed possible issue after deactivating NDI output
    - DMX Monitor: fixed DMX channel value display
    - Fixed cueing line/mask enabled state
    - Fixed possible issue on Windows when OpenGL 3 is not supported
    - Text Generator: fixed fonts on Catalina

    -> https://madmapper.com/yourspace/

    Feel free to share any feedback on the forum or on userfeedback@garagecube.com,

    Enjoy this new beta! :)

    the MADTeam.
    Benoit * garageCube team
  • ilan_katin
    junior Member
    Posts: 1
    Joined: Sat May 25, 2019 12:50 pm

    Re: MadMapper 4 Beta 7 available

    by ilan_katin » Thu Feb 20, 2020 12:03 am

    I downloaded MM 4 beta 7 last night.

    Unfortunately I am not able to use/test it because of the following situation:

    Condition: from the previous usage of Beta 6 I had left the UV panel closed so when I...

    - Launch MM 7
    - Click on the arrow on the upper right side of the panel 'Show/hide the UV view and preview'

    Result:

    - The panel turns white
    - MM beta 7 crashes

    To resolve the problem I tried the following:

    - Launched MM v3 and opened the panel and then quit and opened beta 7
    - Removing ALL MM preferences to see if that would reset the panel state to show the UV view and preview
    - Removing MM 4 beta 7 and re-installing it

    Result: same as indicated above

    The workaround I found was to launch MM 4 beta 7 as logged in as a different user. This worked fine. So the problem is with something MM related in my own user directory.

    Hope this is helpful and any advice is greatly appreciated.
  • mad-matt
    garageCube team
    Posts: 936
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: MadMapper 4 Beta 7 available

    by mad-matt » Mon Mar 23, 2020 3:59 pm

    Hi,
    That's weird, I never heard about such issue.
    Removing ALL MM preferences
    How have you done that ?
    The problem is that macOS stores preferences in a cache, so removing the preferences file might not make any change until a reboot. Another solution is to execute in Terminal "killall -u your_user_login cfprefsd"
    Do if you start Terminal.app, you can make a clean preference cleanup with

    rm ~/Library/Preferences/com.garagecube.MadMapper.plist
    killall -u $USER cfprefsd

    Let me know if it solves the issue in your user account
    Thanks for the report !

Who is online

Users browsing this forum: No registered users and 4 guests