Scene transitions not seamless
  • LiamBM
    junior Member
    Posts: 4
    Joined: Wed Feb 26, 2020 7:49 pm

    Scene transitions not seamless

    by LiamBM » Mon Nov 22, 2021 2:16 pm

    I'm having an issue with Scenes in mad mapper. When one scene transitions to the next, you see the last frame of the video on the new scene before it resets and starts from the beginning again. This means that you don't get smooth transitions. It seems to be a bug as this only happens after a few loops. Restarting mad mapper seems to fix it for a bit before it happens again. I'm currently using version number 3.7.11.
  • mad-matt
    garageCube team
    Posts: 1183
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Scene transitions not seamless

    by mad-matt » Mon Nov 22, 2021 2:26 pm

    Hi,
    macOS or Windows ? On macOS with "Use Hardware Acceleration" activated, we're using AVFoundation player. For better accuracy, don't use it. In other cases we use FFMPEG Player and this should not happen.
    I remember we fixed something about it but I don't remember if it's in 3.xxx or 4.xxx.
    You can also try re-encoding your movies in HAP codec, that will make it more reactive. Here: https://hap.video/
    What codec are you using ?
    Cheers
    Matt
  • LiamBM
    junior Member
    Posts: 4
    Joined: Wed Feb 26, 2020 7:49 pm

    Re: Scene transitions not seamless

    by LiamBM » Wed Nov 24, 2021 2:30 am

    Hi Matt, this happened on a laptop with decent specs. I tried using both Apple ProRes and H.264 and the issue happened on both of them. I also turned hardware acceleration on and off and found that it would still occur. Oddly I even tried the latest madmapper but still had issues. I'll have to double-check that again just to make sure.

    This may be another issue, but we also have a few stuttering issues when playing back the videos on a projector too. You can noticeably see the animation jump a few frames every now and again. These aren't large files either, normally we play 3-4 HD videos at once max. Let me know if there's anything I could try to narrow down any problems.

    Thanks for the help :)

Who is online

Users browsing this forum: Bing [Bot], Invisible Ray and 3 guests