Auto-Play Cue on startup
  • Invisible Ray
    member
    Posts: 43
    Joined: Mon May 16, 2011 11:50 pm

    Auto-Play Cue on startup

    by Invisible Ray » Fri Dec 17, 2021 3:30 pm

    I'm working with a team running a video installation that is up for several months, and the building with the installation has occasional power outages that cause the computer (2021 mac mini) to reboot. I don't know if MM version matters, but this computer is running MM 4.2.1 and we don't want to upgrade to v5 until after the installation is over (v5 came out in the middle of running the installation).

    I am able to launch the Mad Mapper project when the computer reboots by pointing the project file to the startup items, but I have a couple of issues remaining:

    1. even with "Fullscreen when opening a project at startup" selected, I need to manually switch to fullscreen after a restart
    2. the MM project has two cues triggered by the cue scheduler; "ShowAll" with all Quads visibility on and "ShowNone" with all Quads visibility off
    3. "ShowAll" is the first cue in the scenes/cues and I need it to run on startup, but when I test rebooting, the first cue does not run automatically after the computer reboots
  • mad-matt
    garageCube team
    Posts: 1275
    Joined: Mon Sep 09, 2013 5:50 pm

    Re: Auto-Play Cue on startup

    by mad-matt » Wed Dec 22, 2021 7:27 pm

    1. even with "Fullscreen when opening a project at startup" selected, I need to manually switch to fullscreen after a restart
    This is not a known issue.
    What is selected as "Destination" for your projector ? Did you select manually the external projector ?
    This is a MacMini M1 ? (Apple Silicon ou Intel ?)
    If you quit MM and double click the project file, does it start fullscreen ? Could it be that the projector is not yet detected by macOS when MadMapper starts ? MadMapper should anyway attach to it when it's on but since we're in an unknown situation, we have to investigate.
    Can you check if the same issue happens with the Silicon build of MadMapper 5 ?
    2. the MM project has two cues triggered by the cue scheduler; "ShowAll" with all Quads visibility on and "ShowNone" with all Quads visibility off. "ShowAll" is the first cue in the scenes/cues and I need it to run on startup, but when I test rebooting, the first cue does not run automatically after the computer reboots
    How is it supposed to be triggerred on startup ? Scenes / Cues are either triggered by hand, via a control (MIDI, OSC, DMX...) or via a module (Cue Scheduler, Calendar Scheduler...). You can create a cue scheduler with automation ON (scheduling OFF) and set the automation timing to a very high value so it never triggers after startup... We might have to add a new module / option to trigger a scene or cue on project load, but I see no use, since you can just save your project in the correct initial state, isn't it ?

Who is online

Users browsing this forum: No registered users and 1 guest